System Requirements

From 3DGE Wiki
Revision as of 23:34, 7 October 2014 by Corbin (talk | contribs) (Created page with "The system requirements for each platform are listed below. It is currently unknown what the Macintosh version needs as it is not built from source - neither is the Linu...")

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

The system requirements for each platform are listed below. It is currently unknown what the Macintosh version needs as it is not built from source - neither is the Linux version.

  • Pentium-class 1.0 GHz CPU or faster (1.2 GHz recommended for modern modifications).
  • 128MB RAM (512MB RAM recommended).
  • Hardware accelerated 3D card with OpenGL drivers.
   * The minimum 3DGE supports is a VooDoo card, but don't expect to run anything (even 3DGE) with it, especially using DLIGHTS or 3D models.
  • Either a DOOM, DOOM II, HACX, or Final DOOM IWAD file. HERETIC is supported but must be launched cleanly (i.e. through a batchfile).
  • For Win32:
   * DirectX 7.0 or higher.
   * 3DGE is supported on Windows 95 and higher, however, the less RAM/CPU/GPU you have, the port might not run reliably and/or be unable to run certain mods.
  • For Linux:
   * SDL (Simple DirectMedia Layer) version 1.2.
   * glibc 2.
  • For Dreamcast:
   * Console manufactured before the year 2000 to play burned media.
   * Alternatively, an emulator.
   * VMU with (X) Free Blocks to save game data.